vscode更新导致低版本系统无法登陆的问题

fa最新版vscode登录时会报错,因为一些系统基础软件版本太低了,所以如果不想回退版本,就需要更新一下 ▶ ldd --version #来看一眼自己的glibc版本 ldd (GNU libc) 2.37 Copyright (C) 2023...

attachments-2024-02-WOD0MGWS65bc86f42bd80.png

fa最新版vscode登录时会报错,因为一些系统基础软件版本太低了,所以如果不想回退版本,就需要更新一下

 ▶ ldd --version   #来看一眼自己的glibc版本
ldd (GNU libc) 2.37
Copyright (C) 2023 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

版本够,如果不够你就下载一下新版的然后放到自己的环境变量里


╰─[~ ❤ ▶ strings /usr/lib64/libstdc++.so.6 | grep GLIBCXX  # 看一下 libstdc++版本
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_DEBUG_MESSAGE_LENGTH

发现不够,下载一个新的gcc,我下了12.2

然后进去家目录下的

~/.vscode-server/bin/<remote-id>/bin/

# 我的在这里,你需要改一下自己的 remote id
/home/wanghj/.vscode-server/bin/05047486b6df5eb8d44b2ecd70ea3bdf775fd937/node

修改二进制文件node的启动环境

patchelf --set-interpreter /share/work/biosoft/glibc/glibc-v2.37/lib/ld-linux-x86-64.so.2 --set-rpath /share/work/biosoft/glibc/glibc-v2.37/lib:/share/work/biosoft/gcc/gcc-v12.2.0/lib64 --force-rpath ./node

#修改完以后看一下有没有成功是不是和你设置的一样

patchelf --print-interpreter ./node
patchelf --print-rpath ./node

改完以后还需要改一下check文件,在这里

~/.vscode-server/bin/<remote-id>/bin/helpers/check-requirements.sh

在前面加一个exit 0 跳过检查

然后就能进去了

  • 发表于 2024-02-02 14:24
  • 阅读 ( 211 )
  • 分类:软件工具

你可能感兴趣的文章

相关问题

0 条评论

请先 登录 后评论
xun
xun

电路元件工程师

61 篇文章

作家榜 »

  1. omicsgene 652 文章
  2. 安生水 321 文章
  3. Daitoue 167 文章
  4. 生物女学霸 120 文章
  5. 红橙子 78 文章
  6. CORNERSTONE 72 文章
  7. rzx 63 文章
  8. xun 61 文章