安装gdal报错

安装gdal报错

在安装gdal时报一下错误:

sudo yum install gdal gdal-devel


Last metadata expiration check: 3:25:35 ago on Tue 13 Jun 2023 07:28:50 AM CST.
Error:
 Problem 1: package gdal-libs-3.4.0-2.el9.x86_64 requires libarmadillo.so.10()(64bit), but none of the providers can be installed
  - package gdal-3.4.0-2.el9.x86_64 requires libgdal.so.30()(64bit), but none of the providers can be installed
  - package gdal-3.4.0-2.el9.x86_64 requires gdal-libs(x86-64) = 3.4.0-2.el9, but none of the providers can be installed
  - package armadillo-10.8.2-4.el9.x86_64 requires libarpack.so.2()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libflexiblas64.so.3()(64bit) needed by arpack-3.8.0-4.el9.x86_64
 Problem 2: package gdal-libs-3.4.0-2.el9.x86_64 requires libarmadillo.so.10()(64bit), but none of the providers can be installed
  - package gdal-devel-3.4.0-2.el9.x86_64 requires libgdal.so.30()(64bit), but none of the providers can be installed
  - package gdal-devel-3.4.0-2.el9.x86_64 requires gdal-libs(x86-64) = 3.4.0-2.el9, but none of the providers can be installed
  - package armadillo-10.8.2-4.el9.x86_64 requires libarpack.so.2()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libflexiblas64.so.3()(64bit) needed by arpack-3.8.0-4.el9.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

locate查看下有无libflexiblas64.so.3库:

locate libflexiblas64.so.3

没有,需要安装一下:

sudo dnf makecache
sudo dnf install epel-release -y
sudo dnf --enablerepo=crb install flexiblas-devel -y
sudo dnf install arpack -y

重新安装gdal 没有报错了。

sudo yum install gdal gdal-devel


  • 发表于 2023-06-13 11:31
  • 阅读 ( 4430 )
  • 分类:linux

你可能感兴趣的文章

相关问题

0 条评论

请先 登录 后评论
安生水
安生水

333 篇文章

作家榜 »

  1. omicsgene 665 文章
  2. 安生水 333 文章
  3. Daitoue 167 文章
  4. 生物女学霸 120 文章
  5. 红橙子 78 文章
  6. CORNERSTONE 72 文章
  7. xun 69 文章
  8. rzx 68 文章