5 运行WGCNA代码时出现下图报错,下载packageGO.db显示版本不对,是不支持最新版本吗。这一步不解决无法进行下面所有操作,请问老师如何解决

attachments-2023-01-mkkAWWh763b8de6fa1cda.pngattachments-2023-01-psN2NZMn63b8de7794dfb.png

请先 登录 后评论

最佳答案 2023-01-09 19:31

试一下这样安装:

if (!requireNamespace("BiocManager", quietly = TRUE))
    install.packages("BiocManager")
BiocManager::install("GO.db")


最后会询问是否更新相关的包,根据情况任选一个即可,我选了n。之后就安装成功了。

Update all/some/none? [a/s/n]: n
请先 登录 后评论

其它 0 个回答

  • 2 关注
  • 0 收藏,133 浏览
  • 抛抛抛 提出于 2023-01-07 10:53

相似问题